Jump to content


Photo

Hiding IP address while surfing


  • Please log in to reply
8 replies to this topic

#1 Kris

Kris

    Member

  • Members
  • PipPip
  • 21 posts

Posted 03 September 2007 - 12:00 PM

My office internet connection is shared between 3 PCs connected through a router. How do I hide my IP address if I want to surf anonymously? I have tried software that help you Hide IP or Invisible browsing. But nothing seems to work. Is there any solution ? Thanks.

;)

#2 snodger

snodger

    Grumpy old man

  • Members
  • PipPipPipPipPip
  • 1,860 posts

Posted 03 September 2007 - 04:25 PM

From what you say in your post, you are probably connected to an NAT router. On your local network all machines, including the router will have a private IP address. When you connect to the Internet it is the router, not your computer, that has the public IP address.

Have you tried using a proxy site to hide your (i.e. your router's) IP address from the site you really want to visit?

I'm not sure what you have been doing that fails. You mention "software that help you Hide IP or Invisible browsing". Are you referring to software you have installed on your computer? Have you tried JAP. You might be able to configure proxy settings unless access to JAP is blocked.

http://anon.inf.tu-d...e/index_en.html

#3 Kris

Kris

    Member

  • Members
  • PipPip
  • 21 posts

Posted 04 September 2007 - 12:50 PM

It is just a Dlink router with 4 ethernet port. I have installed "Invisible Browsing" software that are supposed to hid my public IP address with a proxy IP. But when I when to dslreports.com, under tools sectiion, to check my IP it states correctly my public IP address and NOT the proxy IP that is configured by the software. This means that other websites will also be able get my actual IP. I have not tried JAP. Is it because I am behind a router and not connected directly to the modem ? I may want to surf anonymously, but the other guy in the office may not, or he/she might need to log in to certain websites that need the real IP address. So maybe it is not possible to hid the IP if you are sharing an internet connection through a router. Any suggestion? Thanks

Edited by Kris, 04 September 2007 - 12:52 PM.


#4 WarXchild

WarXchild

    Administrator

  • Admin
  • PipPipPipPipPip
  • 1,603 posts

Posted 06 September 2007 - 07:32 AM

It is possible to hide your IP on a shared connection, while your colleague uses the connection normally. Invisible Browsing (IB) uses a public proxy list to route your tarffic through the net. A proxy comes in many flavors, the one you need to use with IB is an anonymous proxy, one that hides the "X-FORWARDED" field in your requests. THe proxy you were using most likely does not, and thus your IP is still visible.

Try this. Use your connection normally and access this page http://www.p2plife.com/ip.php . It should list your router IP as the REMOTE-ADDR field, while the X_FORWARD field would be the same or empty.

Now use IB and try that page again, the REMOTE-ADDR should be the proxy IP, if X-FORWARD is empty then you are hidden, if X-FORWARD contains your IP then you are using a non-anonymous proxy, therefore you are not hidden.

#5 Kris

Kris

    Member

  • Members
  • PipPip
  • 21 posts

Posted 06 September 2007 - 01:29 PM

I followed your suggestion. Without using IB, the Remote-addr field is not my router IP but my public IP. And the X-forwarded field is a different IP. There is no different even if I use IB. The IP listed and chosen in IB are all anonymous IP. I tried several IP listed, the result is the same. Is there something I am missing somewhere in using IB? Thanks

#6 WarXchild

WarXchild

    Administrator

  • Admin
  • PipPipPipPipPip
  • 1,603 posts

Posted 11 September 2007 - 09:55 PM

When i mentioned router IP, i did mean the public IP.

Are you using an ISP that is already using a proxy server to filter internet sites?

What was the X-forward when connecting without IB?

When using IB, no matter what proxy you choose, the Remote-ADDR should never be your router/public IP, unless you did not configure IB properly. Remember you need to enter the IB IP and port in tools -> internet options -> connections -> LAN settings -> "use a proxy server for your lan", if you do not, you will not be going through the IB client (as if you are not using IB).

#7 Kris

Kris

    Member

  • Members
  • PipPip
  • 21 posts

Posted 13 September 2007 - 12:08 PM

I do not know whether my ISP is using a proxy server or not. The X-forward is xx.xxx.xxx.xxx
I followed your instructions. I entered the IB IP and port in tools-internet options-connections-LAN setting-Use a proxy server for you lan. After doing this I cannot even access the internet at all.

I thought the software is suppose to configure all the setting for us. I even tried HIDE IP software. The result is the same. Anyway I think I am giving up.

Thank you very much.

Edited by Kris, 19 September 2007 - 10:47 AM.


#8 rik1

rik1

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 November 2007 - 03:34 PM

I do not know whether my ISP is using a proxy server or not. The X-forward is xx.xxx.xxx.xxx
I followed your instructions. I entered the IB IP and port in tools-internet options-connections-LAN setting-Use a proxy server for you lan. After doing this I cannot even access the internet at all.

I thought the software is suppose to configure all the setting for us. I even tried HIDE IP software. The result is the same. Anyway I think I am giving up.

Thank you very much.


for me I ussed ghostsurf and it works for me

#9 collinsmatte

collinsmatte

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 14 March 2013 - 12:00 AM

Try checking vpn's hidemyass.com. By the way what kind of software did you used before in trying to hide your IP Address?




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users